DisplayPort Screen Blank after Boot or Sleep with Asus STRIX GTX 970 Series

By Jake Edwards | Sunday, March 27th, 2016 | Permalink | 4 Comments

Seems there’s an issue with the Asus Strix GTX 970 card when using specifically the DisplayPort (DP) connector on certain monitor models.

Symptoms

I found my screen (Dell U2713H) would suggest there was “No Signal” coming from the PC at certain times. More confusingly, intermittently;

  • Black screen/No Signal when first turning on the PC
  • Black screen/No Signal when resuming from Sleep
  • Black screen/No Signal between the Windows 10 boot screen and the login screen.

Solution

When you finally get it too boot without issue, you need to update the VBIOS of your graphics card.

I believe I was on version 84.04.36.00.AS15, however since updating to 84.04.84.00.AS17 I haven’t had an issue.

You can download the new VBIOS from Asus’ Support Website. It has the description “Fix DP display issue with certain monitors”

There are some older VBIOS versions too; 84.04.2F.00.AS05 & 84.04.1F.00.AS13 & 84.04.1F.00.AS08 though I can’t confirm they had the same issue.

If you need to check the version of your VBIOS, you can use the GPU Tweak II download on the same page (though don’t trust the LiveUpdate as it didn’t pick up this update).

Asus STRIX GTX970 on GPU Tweak II

 

  1. Hello

    How do you actually install bios update?

    Comment by invo1 — June 17, 2016 @ 11:02 pm

  2. The download is a .exe (strix970.exe).
    Run it on the computer that’s having the issue.

    Comment by Jake Edwards — August 18, 2016 @ 2:12 pm

  3. I ran the update and running the same vBios version but the problem remains. 🙁

    Comment by Shukry Rashid — September 13, 2016 @ 9:10 pm

  4. hey came across your post and thanks! had the problem for ages and thought my card was on its way out. Much appreciated!!

    Comment by Shaun — February 1, 2017 @ 6:32 am

Leave a comment